Tag: gemfile

Gemfile – Ein format zur Beschreibung von gem-Abhängigkeiten für Ruby-Programme. Ein Gemfile beschreibt die gem-Abhängigkeiten erforderlich, zum ausführen von zugehörigen Ruby-code.

Warum nicht "rails s" arbeiten aus dem app-Verzeichnis?

Anzahl der Antworten 7 Antworten
Ich bin in meinem app-Ordner, aber der Befehl rails s funktioniert nicht. Ich Las schon ein paar Beiträge auf Stack Overflow, und die meisten von Ihnen scheinen von Benutzern, die nicht in Ihrem app-Verzeichnis. Zusätzlich baute ich

Der Umgang mit bundler-updates (Gemfile.Schloss) im kollaborativen Kontext?

Anzahl der Antworten 1 Antworten
Habe ich schon ein einsamer Programmierer für ein bestimmtes Projekt, aber jetzt jemand anderes hat sich als Kollaborateur. Mit nur mir im Bild bundler updates wurden weich, und ich hätte nie gedacht, zweimal über Gemfile.lock wird von

Was ist die Verwendung von Gemfile in rails?

Anzahl der Antworten 5 Antworten
Was ist die Verwendung von Gemfile in rails? Wie zu verwenden Gemfile? InformationsquelleAutor der Frage vijay | 2012-12-28

Ihre Ruby-version 2.0.0, aber Ihre Gemfile angegeben 2.1.0

Anzahl der Antworten 12 Antworten
Wenn ich versuche zu bündeln, zu installieren bekomme ich folgende Meldung: Your Ruby version is 2.0.0, but your Gemfile specified 2.1.0 In meinem Gemfile habe ich Folgendes: ruby '2.1.0' Und wenn ich laufen ruby -v in der

Wie halte ich alle gems im Gemfile-kompatibel nach update

Anzahl der Antworten 3 Antworten
Meine Frage schon gefragt wurde hieraber ich versuche zu verstehen was die Gründe dafür sind im Gegensatz zu wie das zu umgehen. Die Fehler, die ich bekam, war; You have already activated rspec-core 2.7.1, but your Gemfile

Was ist der Unterschied zwischen Gemfile und Gemfile.lock in Ruby on Rails

Anzahl der Antworten 3 Antworten
Ich bin ein Anfänger, Ruby on Rails, und ich bin mit Rails 3.0.9. Was ist der Unterschied zwischen Gemfile und Gemfile.lock in Rails? InformationsquelleAutor der Frage Shamith c | 2011-08-03

Was bedeutet "falsch" in Gemfile?

Anzahl der Antworten 5 Antworten
Tut: gem 'whenever', require: false bedeutet, dass das gem installiert werden muss, oder bedeutet es, es ist nicht erforderlich? InformationsquelleAutor der Frage rafamvc | 2011-01-26

Ruby Bundler mehrere Quellen in Gemfile

Anzahl der Antworten 4 Antworten
Muss ich sicher einige von meinen gems installiert sind, von unserer eigenen gem-repository anstatt rubygems, während der rest der Installation von rubygems. Kann ich dies im Gemfile, ohne sich Gedanken über eine Namensgebung in Konflikt mit einer

Was kann ich gegen einen Bundler :: GemfileNotFound Fehler tun?

Anzahl der Antworten 6 Antworten
Ich gerade installiert bundler-1.3.3 erfolgreich. Jedoch, wenn ich versuche zu laufen bundle installieren bekomme ich Bundler::GemfileNotFound Was ist hier falsch? InformationsquelleAutor der Frage user1420042 | 2013-03-13

Understanding Gemfile.lock: Ist es in Ordnung, Gemfile.lock zu löschen und die Bundle-Installation erneut auszuführen?

Anzahl der Antworten 3 Antworten
Würden wir dies zu testen, aber nicht riskieren wollen zerstören unsere dev-Umgebung, wenn dies nicht geschehen soll. Ist es in Ordnung, zu löschen Gemfile.lock? Sind wir on Rails 3.0.6. InformationsquelleAutor der Frage Crashalot | 2013-01-11

Gem :: LoadError für mysql2 gem, aber es ist bereits in Gemfile

Anzahl der Antworten 13 Antworten
Gem::LoadError Specified 'mysql2' for database adapter, but the gem is not loaded. Add `gem 'mysql2'` to your Gemfile Dieser Fehler ist aufgetreten beim laden der folgenden Dateien: active_record/base Dies ist der Fehler, bekomme ich auf dem rails

Was ist der Unterschied zwischen ~ & gt; und & gt; = bei der Angabe von Rubygem in Gemfile?

Anzahl der Antworten 2 Antworten
Sehe ich oft die folgende notation(~>) im Gemfile. gem "cucumber", "~>0.8.5" gem "rspec", "~>1.3.0" Ich kenne das-Zeichen (>=) ist einfach größer oder gleich, aber was tut (~>) - notation bedeutet? Sind Sie beide gleich oder hat jeden

bundle install returns "Konnte Gemfile nicht finden"

Anzahl der Antworten 7 Antworten
Ich bin neu auf Schienen und arbeite zurzeit durch eine Führung. Die Anleitung besagt: Verwenden Sie einen text-editor aktualisieren, der Gemfile benötigt Bundler mit der Inhalt von Listing 2.1. source 'https://rubygems.org' gem 'rails', '3.2.3' group :development do

Bei der Installation von debugger-linecache (1.1.1) ist ein Fehler aufgetreten, und Bundler kann nicht fortfahren

Anzahl der Antworten 3 Antworten
Irgendeine Idee, wie man dieses Problem beheben? Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /home/durrantm/.rvm/rubies/ruby-1.9.3-p194/bin/ruby extconf.rb checking for vm_core.h... no checking for vm_core.h... no Makefile creation failed ************************************************************************** No source for ruby-1.9.3-p194 provided with debugger-ruby_core_source gem.

Bundler konnte keine kompatiblen Versionen für Gem finden

Anzahl der Antworten 5 Antworten
Ich habe ein gem 'koala' zu meinem Gemfile und scheint geworfen haben gem-Versionen aus dem Gleichgewicht geraten, wenn ich run 'bundle install' - Befehl: Bundler could not find compatible versions for gem "faraday": In snapshot (Gemfile.lock): faraday

Unterschied zwischen Juwel und erfordern (erfordern Open-URI)

Anzahl der Antworten 2 Antworten
Ich wollte nur zu verstehen für mein selbst. Ich bin mit dem nokogiri gem (zum Parsen von HTML). Wenn ich es Recht zum öffnen von URLs, die ich brauche, um zu verwenden, eine Methode aus der gem