Tag: pip

pip ist ein Ersatz für easy_install, soll eine verbesserte Python package installer.

Wie zu installieren PyPi-Pakete mit anacaonda conda Befehl

Anzahl der Antworten 2 Antworten
Wenn mit der Anacoda Python-distribution, was ist der beste Weg, um installieren einen PyPi-Paket, das nicht direkt über Anaconda? Für jetzt bin ich mit: conda pipbuild [pypi_name] conda install --use-local [package_spec] Aber ich bin mir unklar, ob

Kann ich mit Artifactory mit Python-PIP?

Anzahl der Antworten 3 Antworten
Kann ich ziehen, Python Artefakte von Artifactory mit Pip? Sehe ich, dass ich kann Artefakte in Artifactory mit Python, aber was ist, wenn ich ziehen will Artefakte aus es mit pip? InformationsquelleAutor BestPractices | 2012-08-16

Wie installiere ich ein pip-Paket Global statt lokal?

Anzahl der Antworten 3 Antworten
Ich versuche zu installieren flake8 Paket mit pip3 und es scheint, dass es weigert sich zu installieren, weil bereits installiert in einem lokalen Standort. Wie kann ich die Kraft es zu installieren Global (system-Ebene)? pip3 install flake8

Installieren tensorflow auf Ubuntu 14.04

Anzahl der Antworten 1 Antworten
Ich versuche zu Folgen diese Anweisungen sudo apt-get install python-pip python-dev sudo pip install tensorflow [email protected]:~$ sudo pip install tensorflow Downloading/unpacking tensorflow Could not find any downloads that satisfy the requirement tensorflow Cleaning up... No distributions at

Python - cant find pip.ini-oder pip.conf in Windows

Anzahl der Antworten 8 Antworten
Ich habe Python 2.7.8 installiert auf meinem Win7 Rechner, der kommt mit pip bereits installiert ist. Ich bin erfolgreich in der Lage, die Installation neuer Pakete von pip und nun muss ich hinzufügen, benutzerdefinierte repository-url zu der

Süd: Unbekannter Befehl 'migrieren'

Anzahl der Antworten 6 Antworten
Bin ich ein gnadenloser $ python manage.py migrate Unknown command: 'migrate' Type 'manage.py help' for usage. Zog ich den code von github auf ein frisches computer. Dieser code ist getestet und funktioniert auf anderen Computern. Der gesamte

Ubuntu: pip funktioniert nicht mit Python ist3.4

Anzahl der Antworten 3 Antworten
Versuchen, um pip funktioniert auf meinem Ubuntu-pc. pip scheint zu funktionieren für python2.7, bei anderen aber nicht. Hier ist das problem: $ pip Traceback (most recent call last): File "/usr/local/bin/pip", line 9, in <module> load_entry_point('pip==1.4.1', 'console_scripts', 'pip')()

python-pip auf dem Windows - Befehl "cl.exe' ist fehlgeschlagen

Anzahl der Antworten 8 Antworten
Ich versuche zu installieren spacig mit pip install spacy aber ich bin immer folgende Fehlermeldung .. Habe ich VS 2015 installiert, und ich habe das folgende Python installieren .. 3.5.2 |Anaconda 2.5.0 (64-bit)| (default, Jul 5 2016,

Die Installation von NumPy mit pip schlägt auf Ubuntu

Anzahl der Antworten 4 Antworten
Wenn ich versuche: $ sudo pip install numpy auf meinem Ubuntu 12.04 server habe ich bekommen: ------------------------------------------------------------ /usr/local/bin/pip run on Tue Dec 10 18:25:54 2013 Downloading/unpacking numpy Getting page https://pypi.python.org/simple/numpy/ URLs to search for versions for numpy:

pip install dependency-links

Anzahl der Antworten 3 Antworten
Ich bin mit python version 2.7 und pip version is 1.5.6. Ich installieren möchten, zusätzliche Bibliotheken von url, wie ein git-repo auf setup.py installiert wird. Ich wurde, extras in install_requires parameter in setup.py. Das bedeutet, meine Bibliothek

die Installation eines Python-Pakets Quell-tarball mit pip

Anzahl der Antworten 1 Antworten
Ich versuche, herauszufinden, wie zu konstruieren ist eine Python-source-Paket, das installiert werden via pip. Ich habe versucht, erstellen ein test-Projekt mit der setup.py -Datei beschrieben, die auf http://packages.python.org/an_example_pypi_project/setuptools.html und eine Reihe von einfachen test-Dateien in den angegebenen

Bitte erläutern Sie die Verwendung von Pipfile und Pipfile.lock

Anzahl der Antworten 1 Antworten
Scheint es, dass Pipfile/Pipfile.sperren sind vorgesehen als Ersatz für requirements.txt im Rahmen der Python-Verpackung. Es gibt nicht viel Dokumentation gibt es, wie diese eigentlich funktionieren, jedoch. Ich fand eine sich weiterentwickelnde Beschreibung der pipfile auf der PyPi-Abschnitt

How to install libxml2 in virtualenv?

Anzahl der Antworten 6 Antworten
Habe ich virtualenv mit --no-site-packages option. Ich bin mit scrapy. Scrapy verwendet libxml2 von import libxml2. How to install libxml2 in virtualenv verwenden pip oder easy_install? InformationsquelleAutor Tomasz Wysocki | 2010-10-04

Die Installation von numpy auf Amazon EC2

Anzahl der Antworten 4 Antworten
Ich habe Probleme beim installieren von numpy, die auf einer Amazon EC2-server. Ich habe versucht, mit Hilfe von easy_install, pip, pip in einer virtual env, pip in einem anderen virtuellen env mit python 2.7... Jedes mal, wenn

Zwingen `pip` - so kompilieren Sie eine zuvor installierte Paket (numpy) nach dem Umschalten auf eine andere Python-binary

Anzahl der Antworten 2 Antworten
Diese Frage ist wie vieles eine Frage zu meinem speziellen problem (was ich irgendwie gefunden ein work-around, so dass es nicht ein brennendes Problem), als es sich um den Allgemeinen Prozess, den ich verwende. Setup (der Teil

Wo ist BeautifulSoup4 versteckt?

Anzahl der Antworten 3 Antworten
Habe ich sudo pip install BeautifulSoup4 und bekam eine schrecklich optimistisch Antwort: Downloading/unpacking beautifulsoup4 Running setup.py egg_info for package beautifulsoup4 Installing collected packages: beautifulsoup4 Running setup.py install for beautifulsoup4 Successfully installed beautifulsoup4 Cleaning up.. aber wenn ich

Problem mit easy_install-2.7

Anzahl der Antworten 2 Antworten
Nach der Installation von easy_install und versuchen, es zu benutzen, dann installieren Sie ein python-Paket versagt er. [[email protected]]# easy_install-2.7 pip Searching for pip Reading http://pypi.python.org/simple/pip/ Download error on http://pypi.python.org/simple/pip/: unknown url type: https -- Some packages may

pip wird nicht installiert Python-Pakete lokal mit --user

Anzahl der Antworten 3 Antworten
Ich versuche Pakete zu installieren, die lokal mit pip. Es verwendet, um die Arbeit mit --user aber jetzt wenn ich es versuche, er findet die version des Pakets in /usr/local/lib/ und dann nicht lokal installieren. Normalerweise installieren

Warum ist python sagen, ich habe "no Modul named venv"?

Anzahl der Antworten 2 Antworten
Ich installiert virtual env mit sudo pip install virtualenv aber wenn ich python -m venv flask ich bin noch immer dieser: /usr/bin/python: No module named venv Versionen, falls das relevant ist: pip 1.5.6 from /usr/lib/python2.7/dist-packages (python 2.7)

Python-pip sagt: pkg_resources.DistributionNotFound: pip==1.4.1

Anzahl der Antworten 2 Antworten
Ich habe gerade ein clean install von Ubuntu 14.04 und auch installiert pycharm. Pycharm sagte setuptools und pip waren nicht installiert und angeboten werden, um es zu installieren. Ich habe einfach geklickt "Ÿes" und es schien, um