Sonntag, April 5, 2020

Gewusst wie: überprüfen version auf HP-UX

Ich bin neu in der HP-UX system-und haben ein problem mit der Ausführung einer make-Datei.

Make: Must be a separator on rules line 14.  Stop.

Ich vermute, dies ist aufgrund der älteren version machen das Deployment auf die Maschine (da Sie die gleiche Datei funktioniert auf anderen unix-und linux-basierte Betriebssysteme).

Fragen:-

  • Wie überprüfe ich die version von make (HP-UX verwendet GNU stellen?) auf HP-UX
  • Wie Sie ein upgrade machen auf eine neuere version.

Versuchte ich erste Informationen über die Verwendung man make aber konnte nichts finden auf der version.

Dank.

InformationsquelleAutor Ankur | 2011-07-25

3 Kommentare

  1. 0

    Irgendwie brute-force-und könnte eine Weile dauern, aber Sie könnten versuchen, listing version Informationen über die gesamte installierte software mit

    $ swlist -a revision -a title 
    

    Dann Suche seine Ausgabe was auch immer Paket sieht aus wie es hätte make in es.

    Referenz

    Mann Seite swlist

    • danke. es hat funktioniert. make-3.81. Aber nicht, ob das GNU make (Das könnte HP-UX eigene Implementierung), die Probleme mit der make-Datei geschrieben, die für GNU-make.
  2. 0

    Meisten Programme haben eine –version wechseln (alle GNU core utilities haben eine).

    • funktioniert nicht. make –version Hersteller: Unbekannt Flagge argument -. Stop.
    • arbeitete auf CentOS (wo meine Datei ist auch in Ordnung). make –version GNU Make 3.81
    • Zumindest kann man ziemlich sicher sein, es ist nicht GNU make. :-/
  3. 0

    Installieren gmake statt! Standard auf hp-ux funktioniert nicht gut mit Makefiles geschrieben werden, kompatibel mit GNU make.

Kostenlose Online-Tests