Tag: android-sdk-tools

SDK-Tools steht eine Download-Komponente für die Android-SDK. Es beinhaltet den kompletten Satz an Entwicklungs-und debugging-tools für das Android SDK.

Android Update SDK-Tools 23.0.5 und avd startet nicht

Anzahl der Antworten 6 Antworten
Läuft bei mir auf Windows 8.1 x 64, die Entwicklung von Android-apps mit ADT-Bundle. Vorher (vor dem Update der Android SDK-Tools) der AVD war die Arbeit sehr korrekt und nach dem update, es sagt der folgende Fehler

Fehler beim Parsen C:\Documents und Einstellungen\<Benutzer>\.android\devices.xml

Anzahl der Antworten 4 Antworten
Seit meinem letzten update der Android-SDK auf Eclipse habe ich folgenden Fehler beim öffnen von Eclipse: Error: Fehler beim Parsen C:\Documents und Settings\.android\devices.xml sichern auf C:\Documents und Einstellungen\.android - \ - Geräten.xml.alt cvc-elt.1: Cannot find the declaration

adb: Kommando nicht gefunden ( innerhalb der Plattform-tools-Verzeichnis ) auf Mac OS X Yosemite

Anzahl der Antworten 2 Antworten
Letztlich versuche ich, die Geräte-id für mein note 5. Habe ich installiert Android Studio zusammen mit dem Platform-Tools 23.1 Wenn ich das terminal benutzen, gehen Sie in den platform-tools Ordner, und geben Sie adb bekomme ich "command

Wie man Visual Studio 2015 installer wissen, dass ich schon Android SDK?

Anzahl der Antworten 4 Antworten
Wenn ich die Installation von Visual Studio 2015, erkannte ich, dass es sagt Java SE Development Kit ist bereits auf dem computer vorhanden ist. Ich denke installer wusste, dass es da environment variables. Das ist, warum ich

Die Installation von Android-Support-offline-Repository

Anzahl der Antworten 6 Antworten
Ich bin versucht, setup-Android Studio + Android SDK auf Linux. Ich war in der Lage, setup-Android Studio and SDK Tools und andere Komponenten, mit Ausnahme der "Unterstützung von Android Repository" (Die download-gehalten nicht) also habe ich heruntergeladen

Android SDK Build-Tool Mehrere Versionen

Anzahl der Antworten 3 Antworten
Muss ich wissen, brauchen wir, um zu installieren, jedes Android SDK Build-Tool, oder nur die neueste ausreichend?. Sehen Sie dieses Bild als Referenz, InformationsquelleAutor der Frage user3141985 | 2014-08-04

Die Einrichtung der Lizenzierung, die Überprüfung der Bibliothek auf Android-Studio

Anzahl der Antworten 4 Antworten
im'triyng zur Umsetzung des Google-Lizenzierung Prüfung in einem Android-Studio app gemacht. Anhand der folgenden Linien: http://developer.android.com/google/play/licensing/setting-up.html scheint tath: Als alternative zum hinzufügen der LVL als library-Projekt, können Sie kopieren Sie die library-Quellen direkt in Ihre Anwendung. Dazu

Ich habe ein Upgrade von Android targetSdk 22 bis 23 und ich bin immer ein NoSuchMethodError. Wie könnte ich dieses Problem beheben?

Anzahl der Antworten 2 Antworten
Hier ist meine config und meine Exception, ich bin mir nicht sicher, wie man dieses Problem beheben? compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.rithmio.coach" minSdkVersion 19 targetSdkVersion 23 } 09-17 22:52:15.645 15249-15249/com.rithmio.coach E/AndroidRuntime﹕ FATAL EXCEPTION: main

Android Studio - Problem mit Android SDK auf Windows 7

Anzahl der Antworten 4 Antworten
Ich habe ein Problem mit der neuesten Entwickler-tool angekündigt, auf der Google i/o 2013 "Android Studio". Ich habe erfolgreich das Programm installiert und bin in der Lage zu starten, einfach nur gut. Ich kann importieren, vorhandene Projekte

Eclipse und Android SDK Problem "aapt.exe hat aufgehört."

Anzahl der Antworten 12 Antworten
Ich habe ein Problem auf meinem Windows 7 64-bit-Maschine mit aapt.exe. Es wirft die folgende Fehlermeldung: aapt.exe has stopped working Seine nicht Projekt bezogen, Da ich versucht habe mehrere Projekte, es scheint zu passieren, mit jeder workspace

Fehler: Bitte wählen Sie Android-SDK, Android Studio 2.0

Anzahl der Antworten 7 Antworten
Bin ich mit Android Studio 2.0 Beta2, und ich bin versucht zu laufen alte Projekt, nutzt die google maps api v1 (Paket com.google.android.Karten)*.jar-Datei. Zum ausführen dieses alte Projekt, das ich brauchen, geben Sie compileSdkVersion älter als die

Wie wiederherstellen Android SDK-Tools zu einer früheren Version?

Anzahl der Antworten 3 Antworten
Ist es möglich, wieder Android-SDK-Tools, die zu einer früheren revision (zum Beispiel aus r17, r16 oder r15)? InformationsquelleAutor der Frage Mehmed Mert | 2012-04-05

Nach der Installation von ADT-Plugin, Willkommen zur Android-Entwicklung Nicht Erscheint

Anzahl der Antworten 5 Antworten
Bin ich stecken nach der installation von Eclipse mit ADT-Plugin. Nachdem alle Schritte abgeschlossen sind, es sollte zeigen, "Welcome to android Development" ist, sondern ich sehe die Entwicklung mit Java. Mein setup ist wie folgt: Java JDK

SDK-Manager konnte nicht installiert werden 'java.exe' locking-Verzeichnis

Anzahl der Antworten 12 Antworten
Habe ich lief in eine seltsame Fehlermeldung, wenn Sie versuchen zu aktualisieren Android SDK Tools zu revision 21 aus revision 20.0.3. Das ADT-plug-in korrekt aktualisiert, so jetzt bin ich an einem stand noch bis aufgelöst. Den ersten

AVD-Emulator stuck on loading screen in Android Studio

Anzahl der Antworten 5 Antworten
Ich beschlossen, zu versuchen, Android Studio 2.0 unter Verwendung von Eclipse in der Vergangenheit, aber ich habe erhebliche Schwierigkeiten, den AVD korrekt geladen. Ich habe getan, ein bisschen googeln und Forschung in das problem, sowohl hier, als

Der automatische import funktioniert nicht für Android-Klassen in Android studio

Anzahl der Antworten 3 Antworten
Arbeite ich an einem Projekt in Android studio. Plötzlich geschah es, dass der automatische import stpped arbeiten in android studio für das Android-Klassen, wie Android.widgets.Textview etc. In der Einstellung für den automatischen import aktiviert ist. Wenn ich

Fehler beim ausführen der sdkmanager --list (Android SDK) mit Java 9

Anzahl der Antworten 6 Antworten
Habe ich heruntergeladen und installiert werden: JDK (jdk-9.0.1_osx-x64_bin.dmg) von Oracle hier Android SDK ( sdk-tools-darwin-3859397.zip ), die von Google hier. Nach der Konfiguration der PATH variable, ich habe versucht mit sdkmanageran die Stelle der android Befehl für

Android SDK Manager - Müssen Sie alle Android-Plattformen installieren?

Anzahl der Antworten 3 Antworten
Ich erst vor kurzem heruntergeladen, die Android-SDK. Herunterladen alle Pakete im SDK-Manager wird viel zu viel Zeit. So Frage ich mich, ob ich den abwählen, alle Plattformen bis auf die Letzte. Oder muss ich alle Plattformen? Vielen

Die Google Cloud Messaging für Android-Bibliothek wurde im SDK-Manager nicht gefunden

Anzahl der Antworten 7 Antworten
Ich versuche zu implementieren, die eine push-Benachrichtigung-Lösung für android.Ich bin die Schritte in der folgenden Anleitung http://www.androidhive.info/2012/10/android-push-notifications-using-google-cloud-messaging-gcm-php-and-mysql/ aber als ich versuchte, installieren Sie das Google Cloud Messaging für Android-Bibliothek mit dem android-sdk(ich bin mit dem neuesten sdk

Android SDK-Ordner belegt viel Speicherplatz. Müssen wir alle System Images behalten?

Anzahl der Antworten 8 Antworten
Gibt es eine Menge von system-images häufen sich auf meiner Festplatte in den android sdk-Ordner. ich kaum den emulator verwenden. Vielleicht einmal in 6 Monaten. Die meisten, die meine Entwicklung direkt auf dem Gerät. Was ich testen

Ist GUI für Android SDK Manager weg?

Anzahl der Antworten 9 Antworten
Habe ich selten etwas zu tun für Android, so bin ich ein bisschen verwirrt. Während zurück gab es zwei Arten von Anlagen - Android Studio und Android SDK. Ich habe die IDEE, so brauche ich nicht Studio.

Eclipse generiert MainActivity.java & amp; activity_main.xml

Anzahl der Antworten 9 Antworten
Auf erstellen Sie ein neues Android Application Projekt MainActivity.java unter Ihrem package-Namen generiert werden sollen, automatisch in src Ordner & activity_main.xml erstellt werden sollte, im inneren layout Ordner. Aber es wird nicht erstellt. Und auch im manifest

Die INI-Datei konnte weder in $ ANDROID_AVD_HOME noch in $ HOME / .android / avd gefunden werden

Anzahl der Antworten 9 Antworten
Kann ich nicht starten Sie eine virtuelle Geräte, die auf android-SDK, wenn ich drücken Sie die start-Schaltfläche AVD-manager, dieser Fehler zeigt auf meinem Bildschirm: Starting emulator for AVD 'AVD_for_Galaxy_Nexus_by_Google' PANIC: Could not find AVD_for_Galaxy_Nexus_by_Google.ini file in $ANDROID_AVD_HOME

PANIC: AVD-Systempfad kann nicht gefunden werden. Bitte definieren Sie ANDROID_SDK_ROOT

Anzahl der Antworten 4 Antworten
Ich versuche, meine erste Ionic-app, aber ich bin immer dieser Fehler, wo es nicht mein Handy suchen und nicht finden, den emulator zu laufen. C:\Users\MART\Dropbox\Ionic\myapp>ionic run android Running command: "C:\Program Files\nodejs\node.exe" C:\Users\MART\Dropbox\Ionic\myapp\hooks\after_prepare\010_add_platform_class.js C:\Users\MART\Dropbox\Ionic\myapp add to body class:

Android SDK auf Mac finden und zu PATH hinzufügen

Anzahl der Antworten 6 Antworten
Habe ich installiert Android Studio auf meinem MacBook Air (OS-Version 10.11 El Capitan) und haben erfolgreich geschrieben, ein kleines "Hallo Welt" - app und installiert auf dem Gerät (Nexus 7) und lief auf AVD. Alle, die ich

Wenn ich ADT lade, bekomme ich den Fehler "Das Android SDK erfordert Android Developer Toolkit Version XX.X.X oder höher?"

Anzahl der Antworten 1 Antworten
Ich nur meine aktualisierten Android-SDK-Tools auf version 21.1. Leider ist dies verursacht einen Fehler, wenn ich laden Sie die Android-Entwickler-Toolkit: Dem Android SDK erfordert Android-Entwickler-Toolkit, version 21.1.0 oder oben. Aktuelle version ist 21.0.1.2012-12-6-2-58. Bitte aktualisieren Sie das

Wie installiert man Android Lollipop in Finsternis?

Anzahl der Antworten 3 Antworten
Diese android Dokumentation sagt, dass die installation von android Lollipop. im Dritten Schritt, der Sie sagt, dass Wählen Sie alles, was unter der Android L Developer Preview Abschnitt und klicken Sie auf Pakete Installieren. Aber ich kann

Native reaktiv: target mit der Hash-Zeichenfolge 'android-X' nicht gefunden

Anzahl der Antworten 7 Antworten
Ich versuche mich zu entwickeln, meine erste reagieren-native Android app. Wenn ich sudo react-native run-android Bekomme ich die folgende Fehlermeldung JS server already running. Building and installing the app on the device (cd android && ./gradlew installDebug)...

Gibt es eine Möglichkeit, die Android SDK-Installation zu automatisieren?

Anzahl der Antworten 10 Antworten
Jetzt habe ich downloaden und installieren Sie das Android SDK und AVD-Manager, und installieren Sie dann die APIs, tools auf der Benutzeroberfläche. Gibt es eine Möglichkeit, diesen Vorgang zu automatisieren? InformationsquelleAutor der Frage dongshengcn | 2011-01-13

Listet das installierte SDK-Paket über die Befehlszeile auf

Anzahl der Antworten 4 Antworten
Möchte ich die Liste der installierten sdk-Pakete durch den Befehl Zeilen.(Für einige Gründe, warum ich die Benutzeroberfläche nicht verwenden) Ich habe einige der Forschung getan und fand heraus, mehrere Kommandos, um eine Liste der verfügbaren Pakete auf

Der Android SDK-Manager kann nicht geöffnet werden

Anzahl der Antworten 11 Antworten
Haben gesucht hier und woanders nach Antworten zu meinen Problemen, ich bin immer noch nicht in der Lage dieses Problem zu beheben. Habe ich installiert, Eclipse, ADT Plugin und Android SDK. Mein problem ist, dass der SDK-Manager

Wie installiere ich alte Build-Tools von Android über die Befehlszeile?

Anzahl der Antworten 4 Antworten
Ich die Installation von android SDK, die zum erstellen eines automatisierten build-server. Ich habe in ein problem, wo viele Gradle-basierte Android-Projekte, die ich zu verwalten, verlassen sich auf verschiedene build-tools-version. Einige der Projekte, die noch mit der

Was sind die Android SDK-Build-Tools, Plattform-Tools und Tools? Und welche Version sollte verwendet werden?

Anzahl der Antworten 6 Antworten
Ich weiß, das ist eine sehr rudimentäre Frage, aber zu meiner überraschung konnte ich nicht finden, ein beliebiges Dokument über die Android SDK Build-tools. Neben der Android SDK Tools und Android SDK Platform-tools, es gibt eine Menge

Starten des Android-Emulators in SDK-Tools, Revision 12

Anzahl der Antworten 11 Antworten
Ich aktualisiert die Android-SDK-tools, die aus der revision 11, revision 12, und der emulator jetzt nicht starten kann. Wenn ich versuche zu laufen emulator.exe ich bekomme: invalid command-line parameter: Files\Android\android-sdk\tools/emulator-arm.exe. Hinweis: verwenden Sie '@foo' zu starten ein

Cordova: [Fehler: Bitte Android Ziel installieren: "android-21"

Anzahl der Antworten 8 Antworten
Ich gerade aktualisiert cordova + ionic in meiner app nach, dass ich erfolgreich installiert Android-SDK-v22 via Android-SDK-manager. Aber nach dem ausführen-Befehl: cordova build android Bekomme ich immer die folgende Meldung: Running command: /Users/peter/workspace/myapp/platforms/android/cordova/build [Error: Please install Android

Android plugin 1.3 Fehler

Anzahl der Antworten 4 Antworten
Diesen Fehler bekam ich, als meine aktualisierten SDK Build-tool zu Android M Android Build Tools Found incompatible Build Tools and Android plugin versions: * Module 'app' is using Android plugin 1.2.3 and Build Tools 23.0.0 rc1 Please

Kann nicht ausführen dex: Mehrere Dex-Dateien definieren Lcom / myapp / R $ -Array;

Anzahl der Antworten 30 Antworten
Seit dem Update auf ADT 14 kann ich nicht mehr bauen, mein Projekt. Es war der Bau Ordnung vor der Aktualisierung. Den Fehler: [2011-10-23 16:23:29 - Dex Loader] Unable to execute dex: Multiple dex files define Lcom/myapp/R$array;

Android Unbekanntes Kommando "Knirschen"

Anzahl der Antworten 7 Antworten
Ich gerade installiert Eclipse und Android SDK unter Mac OS X. Ich importiert das Projekt in Eclipse und bekomme ich das Unknown command 'crunch' Fehler während der Ausführung des Projekts. Wie soll ich dieses Problem lösen. Bitte

Herunterladen des Android SDK-Managers mit falscher Prüfsumme beendet?

Anzahl der Antworten 4 Antworten
Bin ich mit dem Android SDK Manager revision 23.0.5. Ich habe versucht, zu aktualisieren, einige SDK, aber habe diese Fehler. Ich habe versucht, eine Menge Zeit. Und ich versuche, mit "https://" in der option aber nicht. Ich

libz.so.1: kann die freigegebene Objektdatei nicht öffnen

Anzahl der Antworten 8 Antworten
Stehe ich vor einem Problem auf ubuntu 12.04 als : /usr/lib/ndk/android-ndk-r8c/toolchains/arm-linux-androideabi-4.6/prebuilt/linux-x86/bin/../lib/gcc/arm-linux-androideabi/4.6/../../../../arm-linux-androideabi/bin/as: error while loading shared libraries: libz.so.1: cannot open shared object-Datei: Keine solche Datei oder das Verzeichnis Versuchte ich sudo apt-get install lib32z1 Aber es sagt Paketlisten

Android-Emulator stürzt auf Mac ab

Anzahl der Antworten 8 Antworten
Wenn ich versuche zu starten, Android-emulator, es stürzt auf Mac OS X. Er arbeitete einige Zeit her, aber jetzt funktioniert es nicht mehr und ich habe keine Ahnung, warum. Crash-log: http://pastebin.com/04MjCqaS Terminal-log im verbose-Modus: http://pastebin.com/L6y6rUr0 InformationsquelleAutor der

R kann nicht aufgelöst werden - Android Fehler

Anzahl der Antworten 30 Antworten
Habe ich gerade heruntergeladen und installiert ist das neue Android-SDK. Ich wollte eine einfache Anwendung, um zu testen, fahren Sie. Der Assistent erstellt diesen code: package eu.mauriziopz.gps; import android.app.Activity; import android.os.Bundle; public class ggps extends Activity {

Fehlende SDK-Plattform Android, API 18

Anzahl der Antworten 19 Antworten
Während ich versuche zu Installieren, API 18 es zeigt nur "Google API 18"(nichts mehr). Nowif ich versucht zu installieren, diese google-APIs von Android SDK Manager es zeigt eine Meldung "this package depends on "Missing SDK platform Android,

Wie ermittelt man die Android-Version, die auf dem Computer installiert ist?

Anzahl der Antworten 7 Antworten
Wie Sie bestimmen die version des Android-SDK installiert ist, auf meinem computer? InformationsquelleAutor der Frage aton1004 | 2012-12-18

Android Studio SDK wird deaktiviert

Anzahl der Antworten 8 Antworten
Ich gerade heruntergeladen, Android-Studio .dmg für OSX. Gemäß den Installationsanweisungen, die ich gezogen habe es in den Ordner der Anwendung und die Anwendung startete. Aber den SDK Manager und AVD Manager sind, werden ausgegraut und sind nicht

Akzeptieren Sie automatisch alle SDK-Lizenzen

Anzahl der Antworten 30 Antworten
Da gradle android-plugins 2.2-alpha4: Gradle wird versuchen, Sie zu downloaden fehlende SDK-Pakete, die von einem Projekt hängt davon ab, Ist erstaunlich kühl und war wissen ein JakeWharton Projekt. Aber, der download der SDK-Bibliothek müssen Sie die Lizenzvereinbarung

Android Hello-World-Kompilierungsfehler: Intellij kann aapt nicht finden

Anzahl der Antworten 13 Antworten
Ich versuche, einrichten mit einem Android-Entwicklungsumgebung auf der Basis von IntelliJ in Ubuntu 12.04. Ich erstellen eine Android-Anwendung-Modul, aber wenn ich versuche, bekomme ich die folgende Fehlermeldung: android-apt-compiler: Cannot run program "/home/jon/Programme/android-sdk-linux/platform-tools/aapt": java.io.IOException: error=2, No such file

Wie deaktiviert das Herunterladen von Komponenten in Android Studio zuerst

Anzahl der Antworten 1 Antworten
Ich nutze Android Studio-IDE 135.1740770, Auch diese Pakete installiert sind, für SDK: Tools - Android SDK-Tools 24.1.2 - Android SDK platform-tools 22 - Android SDK Build-tools 22.0.1 Extras - Unterstützung Von Android-Repository 13 - Android Support-Bibliothek 22.1

Der Android SDK-Speicherort sollte keine Leerzeichen enthalten, da dies zu Problemen mit NDK-Tools führen kann

Anzahl der Antworten 6 Antworten
Kürzlich installiert hab ich die Letzte version von Android Studio (Android Studio 2.1), halten die alte 1.2 version installiert. Jetzt habe ich Android Studio 2.1 und Android Studio 1.2. In Android Studio 1.2 wenn ich auf SDK

Was ist der Unterschied zwischen den Google APIs im Android SDK?

Anzahl der Antworten 4 Antworten
Seit android 5.0, Google Hinzugefügt Google-APIs. was ist das genau? Und was ist der Unterschied zwischen Google-APIs intel atom_64 x86-system-image-und Google-APIs intel-atom-x86-system-image? Ich weiß, die intel atom-images ist viel schneller, aber es gibt eine Menge von Ihnen.