Tag: debian

FRAGEN MUSS DIE PROGRAMMIERUNG VERWANDT. Verwenden Sie dieses tag nur dann, wenn Ihre Frage bezieht sich auf die Entwicklung, die auf Debian mit Betriebssystem-API ‚ s oder Debian-spezifische Funktionen, oder zum erstellen von Paketen im deb-format.

error: 'Access denied for user 'debian-sys-maint'@'localhost' (using password: YES)'

Anzahl der Antworten 3 Antworten
Langjähriger Leser von Stackoverflow, erste Zeit Sie eine Frage. Hatte ich zum hardware-Neustart mein dev Notebook ein paar Nächte her, aus verschiedenen Gründen. Wenn ich brachte es zurück, bis ich merkte, dass mysqld nicht mehr zugänglich. Ich

Jenkins sudo: no tty present and no askpass program specified, mit NOPASSWD

Anzahl der Antworten 3 Antworten
Verbringe ich mehrere Tage die Einrichtung der Datei /etc/sudoers geben zu können Berechtigungen für root an den Benutzer jenkins. Ich habe Jenkins installiert auf meinem server, da ich mehrere Projekte mit symfony -, Ionen -, neo4j, etc...

Wie aktualisiere ich DPKG selbst auf Debian?

Anzahl der Antworten 2 Antworten
Habe ich eine sehr alte version davon und es weigert sich, neu zu installieren .deb-Dateien Dies ist das ursprüngliche problem: Versucht zu installieren, Google ' s mod_pagespeed für Apache. Ergebnis: dpkg: betreffend mod-pagespeed-beta_current_i386.deb mit mod-pagespeed-beta, pre-dependency problem:

Kein Lebenslauf.Punkt in Python-OpenCV über die aktuelle stabile Debian

Anzahl der Antworten 1 Antworten
Wenn Sie versuchen, zeichnen Sie einen Kreis auf ein Bild mit cv.Kreis, erkannte ich, dass es keine cv.Punkt-Funktion zum erstellen einer cvPoint in Python-OpenCV. Ich verwende die neuste stable-version von Debian installiert und ich alle Python-OpenCV-Pakete mit

Pass bash-argument zu einem python-Skript

Anzahl der Antworten 4 Antworten
Ich versuche, erstellen Sie ein bash-Skript übergibt seine eigene argument auf ein python-Skript. Ich will es so. Wenn ich es laufen wie diese: script.sh latest Dann innerhalb der bash-Skript, es läuft ein python-Skript mit dem "neuesten" argument

Wie installiere die aktuelle libcurl auf debian-server?

Anzahl der Antworten 3 Antworten
Ich bin neue auf diese Dinge. Ich weiß nicht, was Befehlszeile erforderlich ist zum installieren der neuesten version von libcurl. Ich folgte einige Artikel gefunden, die auf net, aber ich bekomme Kein akzeptabler C compiler found in

Daemonizing ein python-Skript im debian mit virtualenv

Anzahl der Antworten 2 Antworten
Ich habe gesehen, eine Menge von Skripten für daemonizing ein python-Skript in linux, aber nicht viel Informationen darüber, wie Sie zu verwenden sind. Könnte jemand mich leiten auf diesem? Moment habe ich einen langen python-Skript lauscht auf

Überprüfen, ob ein Paket installiert ist

Anzahl der Antworten 7 Antworten
Ist es eine elegante und mehr Python-ähnliche Art und Weise zu überprüfen, ob ein Paket installiert ist Debian? In ein bash-script, das ich tun würde: dpkg -s packagename | grep Status Vorschläge, das gleiche zu tun in

Compiler kann nicht finden libxml/parser.h

Anzahl der Antworten 3 Antworten
Bin ich auf Debian 8 (Jessie), 64 Bit. Ich installierte libxml2-dev, die sitzt nun in /usr/include/libxml2/libxml. Aber wenn ich das mache (genau wie libxml docs sagen) #include <libxml/parser.h> Bekomme ich nur beim kompilieren (mit gcc) fatal error:

Welches os ist besser für die Entwicklung : Debian oder Ubuntu?

Anzahl der Antworten 6 Antworten
Gibt es echte Unterschiede zwischen Ihnen? Ich soll ein Programm in java und python. Und corse ein normaler Benutzer: internet, etc Die man mir geben wird, weniger Kopfschmerzen/mehr Zufriedenheit ? Ist und was ist besser für einen

uWSGI + nginx für django-Projekt, Fehler mit strting uwsgi

Anzahl der Antworten 2 Antworten
Ich versuche, up-webserver für django auf nginx+uwsgi, os - debian (3.1.0-1-amd64 x86_64) nginx 1.1.8-1, uwsgi 0.9.8.3-1 Konfiguration: <uwsgi> <socket>/tmp/uwsgi.sock</socket> <process>1</process> <master/> <enable-threads/> <uid>33</uid> <gid>33</gid> <pidfile>/tmp/uwsgi.pid</pidfile> </uwsgi> in der Datei /etc/uwsgi/apps-enabled/webapp.xml nginx-Konfiguration location / { uwsgi_pass unix:///tmp/uwsgi.sock; include

Error while loading shared libraries: libpq.so.5: cannot open shared object file: No such file or directory

Anzahl der Antworten 4 Antworten
Ich versuche ausführen pg_dump auf PostgreSQL 9.0.4-server läuft auf Debian und ich erhalte den folgenden Fehler: ./pg_dump: error while loading shared libraries: libpq.so.5: cannot open shared object file: No such file or directory libpq.so.5 ist ein link

unable to import dump mit "imp"

Anzahl der Antworten 2 Antworten
Ich versuche zu import in oracle mit imp Befehl und die Ausgabe des Befehls ist wie folgt. invincible:/home/invincible# imp Import: Release 10.2.0.1.0 - Production on Thu Aug 12 22:19:00 2010 Copyright (c) 1982, 2005, Oracle. All rights

linux debian crontab-job nicht ausgeführt

Anzahl der Antworten 3 Antworten
Habe ich ein bash-script foo.sh befindet sich in der /etc/cron.täglich Verzeichnis, chmoded 700, im Besitz von root-crontab-Liste für den Benutzer root ist unverändert (crontab -l) aus dem Kern-Debian-installation. Ich machte cronjob in einer anderen Weise als mit

Hinzufügen von gmail als smarthost im Debian exim4

Anzahl der Antworten 3 Antworten
Ich würde gerne wissen, wie meine setup-exim4 auf Debian, so dass es mit gmail als smarthost, sondern als meinem ISP. Es scheint müssen die TLS-Einstellungen und natürlich eine gmail-Benutzer-id und Kennwort. Die "standard" smarthost Beispiel, das kommt

Wie kann ich mit PHP mail() zu arbeiten? Brauche Hilfe bei der Konfiguration eines MTA

Anzahl der Antworten 2 Antworten
Update: ich habe es gelöst. Alles dokumentiert unter. Ich habe versucht, so viele Dinge, aber es einfach nicht funktionieren würde. Ich würde nicht dagegen, mit, postfix, exim4 oder sendmail. Ich muss nur eine Schritt-für-Schritt-Anleitung und Erklärung, was

Wo bekommt man iostream.h

Anzahl der Antworten 3 Antworten
Ich versuche, mich etwas in Linux, aber es beschwert sich, dass es nicht finden können iostream.h. Was muss ich installieren, um diese Datei zu erhalten? Dies ist ein Fehler in dem code, den Sie verwenden möchten. Wenn

DNS debian SERVFAIL server nicht gefunden, kein ping

Anzahl der Antworten 1 Antworten
Ich versuche erstellen Sie einen DNS-server in meiner Umgebung zu testen, aber ich weiß nicht binden. Die Einstellungen von meinem server erstellt, mit dem Ergebnis der google-Suche. Bind start ohne Fehler, aber nicht lösen lässt, meine domain.

Verpackungs-Go-Anwendung für Debian

Anzahl der Antworten 5 Antworten
Wie kann ich mein Gehen binary in ein Debian-Paket? Da Gehen ist statisch gelinkt, ich habe nur eine einzige ausführbare Datei--ich brauche nicht eine Menge von komplizierten Projekt-Metadaten-Informationen. Gibt es eine einfache Art und Weise Verpacken Sie

Wie kann man das apt-get update in Debian Lenny, so dass PostgreSql-9.1 können installiert

Anzahl der Antworten 1 Antworten
Versuchte ich apt-get update unter Debian Lenny bekam aber folgenden Fehler. Wie man dieses Problem beheben, so dass PostgreSql-9.1 kann installiert ? root:~# apt-get update Ign http://security.debian.org etch/updates Release.gpg Get:1 http://archive.debian.org Debian-4.0 Release.gpg [1033B] Get:2 http://archive.debian.org etch-backports

How to install g++ - 4.9 von Debian-Wheezy-armel?

Anzahl der Antworten 4 Antworten
Meinem Debian 7 armel embedded-system derzeit hat g++ 4.6 und ich hätte gerne das upgrade auf g++ 4.9 Nutzung der neuen C++11 Funktionen. Wie mache ich das? Meine aktuellen Quellen.Liste den Inhalt ist: deb http://security.debian.org/wheezy/updates main deb-src

Wie curl installieren auf debian 7.1? Immer den folgenden Fehler an " apt-get install curl

Anzahl der Antworten 2 Antworten
Die folgenden Pakete haben unerfüllte Abhängigkeiten: curl : Hängt ab: libcurl3 (= 7.26.0-1+wheezy2) ist aber nicht installierbar E: kann Probleme zu korrigieren, Sie haben gehaltene kaputte Pakete. apt-get remove apt-listchanges apt-get install curl diese erhalten Sie es

Apache2 "configtest failed" beim Versuch neu zu starten

Anzahl der Antworten 2 Antworten
ich versuchte, Sie zu schützen Sie ein Verzeichnis in meinem www-Ordner mit einem .htaccess-Datei, die keinen Effekt hatte, also änderte ich die Zeile AllowOverride None in meiner apache2.conf AllowOverride All als root. nun sehe ich, dass das

Gitlab auf port 8080

Anzahl der Antworten 2 Antworten
Ich bin derzeit in den Prozess der versucht zu bekommen omnibus-Gitlab installiert auf meinem privaten Debian-server, und es funktioniert perfekt auf port 80, das problem ist, ich habe auch einen Apache-server lauscht auf port 80. Also ich

PostgreSQL - JDBC-Treiber Installieren

Anzahl der Antworten 4 Antworten
Ich habe eine harte Zeit, wie ich sein sollte, installieren Sie den JDBC-Treiber für PostgreSQL auf meinem debian 6.0 server. Ich zog den Fahrer .jar in das folgende Verzeichnis: /usr/local/pgsql/share/java/postgresql.jar. Dann die tutorials sprechen über die Verwendung

Debian-apt Fehlermeldung: "Die folgenden Signaturen waren ungültig: NODATA 1 NODATA 2"

Anzahl der Antworten 3 Antworten
Ich habe einige Schwierigkeiten mit apt/aptitude. Vor kurzem, aus dem nichts, ich merkte, ich konnte nicht alles installieren und apt-get update produzieren würde dieses Ergebnis: $ sudo apt-get update Get:1 http://security.debian.org wheezy/updates Release.gpg [1,936 B] Get:2 http://ftp.debian.org

Wie vergleichen Sie das Debian-Paket-Versionen?

Anzahl der Antworten 2 Antworten
Schaute ich python-apt und python-debian, und Sie scheinen nicht zu haben Funktionalität zum vergleichen von Paket-Versionen. Muss ich schreiben, dass meine eigenen, oder ist es etwas, das ich benutzen kann? Idealerweise sollte es so Aussehen: >>> v1

Nicht stellen Sie eine einfache JNI-Programm auf Debian Wheezhy

Anzahl der Antworten 2 Antworten
Installiert hab ich R auf einem Debian Wheezhy. Ich installieren möchte rjava-Paket, aber ich bekomme diese Fehlermeldung: configure: error: Cannot compile a simple JNI program. See config.log for details. Make sure you have Java Development Kit installed

Kali Linux (Debian) lässt sich nicht installieren pip.py

Anzahl der Antworten 3 Antworten
Ich versuche zu installieren "python-pip", auf kali linux (debian abgeleitete distribution), mit dem Befehl unten: apt-get install python-pip Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package python-pip Bin ich

Erstellen kann die JVM mit -XX:+UseLargePages aktiviert

Anzahl der Antworten 1 Antworten
Ich habe ein Java service, der läuft momentan mit einer 14GB heap. Ich bin begierig darauf, zu versuchen, die -XX:+UseLargePages option, um zu sehen, wie könnte dies Auswirkungen auf die Leistung des Systems. Habe ich so konfiguriert

Linux-Debian - unerfüllten Abhängigkeiten

Anzahl der Antworten 1 Antworten
Wie kann ich Sie entfernen unerfüllten Abhängigkeiten auf meinem Linux Debian? Ergebnis apt-get -f install ist folgende: Paketlisten werden gelesen... Fertig Building dependency tree Reading state information... Fertig Korrigieren von Abhängigkeiten... fehlgeschlagen. Die folgenden Pakete haben unerfüllte

Gewusst wie: importieren sql-Datei in ein bash-script

Anzahl der Antworten 1 Antworten
Auf Debian, ich will zum importieren einer großen sql-Datei mit einem Befehl in ein bash-Skript. Derzeit verwende ich diesen Befehl: mysql -u root -p myDatabase < my_backup.sql Aber das ist nicht schön, in einem bash-Skript, da fragt

Jenkins: console output Zeichen

Anzahl der Antworten 3 Antworten
Weiß jemand, wie schlagen solche chars in Jenkins die Ausgabe der Konsole anmelden? Scheint es ein problem mit UTF-8. InformationsquelleAutor Nicolas Siver | 2015-01-15

Home-Verzeichnis ist voll. Wie zu erhöhen Sie Ihre Größe?

Anzahl der Antworten 2 Antworten
Bitte siehe das Bild unten. Feststellen, dass meine /home Verzeichnis ist bereits zu 100% aber ich habe noch viel Platz auf /dev/mapper/vg00-srv. Gibt es eine Möglichkeit, die ich nutzen kann, um den Platz für meine /home oder

Debian basierte Systeme-Sitzung getötet, in 30 Minuten in speziellen cron, wie zu überschreiben?

Anzahl der Antworten 6 Antworten
Worden herausziehen meine Haare versuchen herauszufinden, warum meine Sitzungen sind terminiert/gekillt/zerstört bei 30 Minuten. Nun, es sieht aus wie Debian-basierte Systeme haben ein spezielles cron ausgeführt, der ignoriert alle php.ini-und apache-Konfigurationen und tötet jede Sitzung im Leerlauf

Wie geben Sie Dateipfad in java?

Anzahl der Antworten 5 Antworten
Habe ich eine java-Anwendung für Debian-Linux." Jetzt möchte ich, dass diese Anwendung liest eine Datei in das Verzeichnis gelegt, wo die jar-Datei der Anwendung angegeben ist. Also, was ist zu geben auf das argument des File-Objekts? File

Die Kombination von 2 .csv-Dateien, die durch gemeinsame Spalte

Anzahl der Antworten 6 Antworten
Habe ich zwei .csv-Dateien, in denen die erste Zeile in der Datei 1: MPID,Title,Description,Model,Category ID,Category Description,Subcategory ID,Subcategory Description,Manufacturer ID,Manufacturer Description,URL,Manufacturer (Brand) URL,Image URL,AR Price,Price,Ship Price,Stock,Condition Die erste Zeile von Datei 2: Regular Price,Sale Price,Manufacturer Name,Model Number,Retailer Category,Buy

was ist die Funktion von /etc/apt/sources.Liste.d?

Anzahl der Antworten 1 Antworten
Ich Hinzugefügt LLVM Debian/Ubuntu-übernachtungs-Pakete in der /etc/apt/sources.list.d Verzeichnis wie llvm.list. Dann lief ich apt-get update, bekam aber folgenden Fehler GPG Error: The LLVM Compiler Infrastructure Project llvm-toolchain-trusty InRelease: no public key,can not qulify the signature: NO_PUBKEY 15CF4D18AF4F7421

PHP5-Curl installieren, Fehlermeldung kein installation-Kandidat

Anzahl der Antworten 3 Antworten
Ich installieren möchte PHP5-Curl in meinem Debian-server. Aber wenn ich diesen Befehl ausführen: apt-get install PHP5-Curl Bekomme ich eine Fehlermeldung wie: Reading package lists... Done Building dependency tree Reading state information... Done Package PHP5-Curl is not available,

Die Installation von Mercurial unter Debian Squeeze: hg gibt einen "nicht finden konnte, mercurial Bibliotheken" Fehler

Anzahl der Antworten 3 Antworten
Nach scheinbar erfolgreicher installation auf Debian Squeeze(über apt-get install mercurial), hg weigert sich zu starten, geben diese Fehlermeldung: [email protected]:/tmp/example.com# hg abort: couldn't find mercurial libraries in [/usr/bin /usr/lib/python2.6 /usr/lib/python2.6/plat-linux2 /usr/lib/python2.6/lib-tk /usr/lib/python2.6/lib-old /usr/lib/python2.6/lib-dynload /usr/local/lib/python2.6/dist-packages /usr/lib/python2.6/dist-packages /usr/lib/pymodules/python2.6] (check your

mail() funktioniert nicht auf neuem server

Anzahl der Antworten 1 Antworten
Kann sein das es eine dumme Frage, aber ich kann nicht herausfinden, der Grund, warum php-mail-Funktion funktioniert nicht Ich habe einen nginx server auf debian squeeze, zog ich es vor kurzem. Ich versuchte einfach E-mail-Ausführung, sondern es

Bash-Skript druckt "Befehl Nicht Gefunden" auf leere Zeilen

Anzahl der Antworten 16 Antworten
Jedes mal, wenn ich ein Skript ausführen, mit bash scriptname.sh von der Befehlszeile aus in Debian, bekomme ich Command Not found und dann das Ergebnis des Skripts. Das Skript funktioniert, aber es ist immer ein Command Not

Nicht verwenden, - service-Befehl, mit debian 8 (Jessie)

Anzahl der Antworten 1 Antworten
Zur Installation von LibreOffice 4.4 in mein Debian 8 (Jessie), ich habe gerade alle meine bash-Skripte von meinem Debian 7.5 und führen Sie Sie in der gleichen Weise in das D8 ein. Ich weiß, gab es mehrere

Install libpq-dev-Paket-Fehler

Anzahl der Antworten 2 Antworten
Habe ich versucht zu installieren pg Juwel, und ich habe diese Warnung: Zu installieren, müssen Sie die postgresql-server-dev-X. Y für den Aufbau einer server-side extension oder libpq-dev wird für den Aufbau einer client-Seite - Anwendung. So, ich

Fügen Sie 10-minütigen cron-job, um Ubuntu-Paket

Anzahl der Antworten 1 Antworten
Muss ich installieren, werden einige cron-jobs mit meiner Ubuntu-installation-Paket. Diejenigen, die jeden Tag oder Stunde sind einfach: ich kann einfach erstellen Sie einen symbolischen Link von /etc/cron.daily auf mein Skript. Allerdings habe ich auch ein Skript, dass

Amazon AWS EC2-Instanz keine Verbindung mit SSH

Anzahl der Antworten 7 Antworten
Dieser nicht so schwer sein sollte. Ich kann keine Verbindung zu neuen AWS EC2 Instanz via SSH-clients. Ich bin die Verbindung von einem Win 7-Rechner. Instanz OS: Debian 6 AMI: debian-squeeze-i386-20121119-e4554303-3a9d-412e-9604-eae67dde7b76-ami-1977f070.1(ami-a121a6c8) Benutzer: versucht root und auch ec2-user

Wie aktualisiert Certbot version?

Anzahl der Antworten 4 Antworten
Ich bin mit certbot --apache aber ich bekomme die folgende Fehlermeldung: Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org Obtaining a new certificate Performing the following challenges: Client with the currently selected authenticator does not support any combination of

"start-stop-daemon: unable to stat" -

Anzahl der Antworten 1 Antworten
ich habe Folgendes start-stop-Skript: NAME="examplestartstop" PATH="/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/opt/node/bin" LOGFILE="/var/log/$NAME/start-stop-daemon.log" APP_DIR="/usr/bin" APP_BIN="tail -250f /var/log/apache2/error.log" USER="minecraft" GROUP="minecraft" # Include functions set -e . /lib/lsb/init-functions start() { echo "Starting '$NAME'... " start-stop-daemon --start --chuid "$USER:$GROUP" --background --make-pidfile --pidfile /var/run/$NAME.pid --exec "$APP_DIR/$APP_BIN" $LOGFILE

debian rules-Datei erstellen Sie einen symbolischen Link

Anzahl der Antworten 1 Antworten
Ich bin ein kleines deb-Paket zu installieren, ein paar Dateien. Einige von Ihnen befinden sich in /usr/lib/MeinPaket/und ich möchten, erstellen Sie einen symbolischen Link von /usr/lib/MeinPaket/mybin /usr/bin/mybin Den /usr/lib/MeinPaket Ordner ich bin mit MeinPaket.installieren und kopieren Sie

W: Failed to fetch http://deb.debian.org/debian/dists/jessie-updates/main/binary-amd64/Packages 404 not Found [IP: 151.101.140.204 80]

Anzahl der Antworten 2 Antworten
Ich versuche, ein Projekt am laufen lokal auf Deepin. Das Projekt stützt sich auf Knoten 6.10, ich verstehe, dass es eine alte version, aber es funktioniert. Wenn das Dockerfile versucht zum ausführen der sudo apt-get update, es